# Table of Contents

**Introduction** .................................................................................................................. 3

How to Use this Document ................................................................................................. 3

## Basic Administration

- Registering as a User on the PNA ................................................................................. 4
- Sharing Drives Between the PNA and a PC ................................................................. 6
- Determine the Full Computer Names of Both Devices ............................................. 6
- Share the PNA's C Drive .............................................................................................. 7
- Map a New Drive on the PC ......................................................................................... 7

## Installing Software

- Installing Software Over the LAN ............................................................................... 8
- Map the PC's CD-ROM Drive to the PNA .................................................................... 8
- Install the Software ....................................................................................................... 8
- Installing Software from External USB CD-ROM Drive .............................................. 9
- Connect the External CD Drive to the PNA ............................................................... 9
- Install the Software ....................................................................................................... 9

## Configuring COM/DCOM

- Workgroups versus Domains ....................................................................................... 10
- Granting Access to a Specific User ............................................................................... 10
- Windows® XP Procedure for Granting Access ......................................................... 11
- Windows® 2000 Procedure for Granting Access ...................................................... 11
- Configuring the PC for DCOM Access ...................................................................... 12
- If You Encounter Problems ......................................................................................... 12

## Application Examples

- Microsoft® Visual Basic® Example ........................................................................... 14
- Visual Basic Configuration ......................................................................................... 14
- Visual Basic Code ........................................................................................................ 15
- Visual Basic Output ..................................................................................................... 16
- Microsoft Visual Basic Script (VBScript) Example ................................................ 17
- VBScript Configuration ............................................................................................... 17
- VBScript Code ............................................................................................................. 17
- VB Script Output ........................................................................................................ 18
- Microsoft Word Example ........................................................................................... 19
- Microsoft Word Configuration ................................................................................... 19
- Microsoft Word Code ................................................................................................ 21
- Microsoft Word Output .............................................................................................. 22
- Microsoft Excel Example ............................................................................................ 23
- Microsoft Excel Configuration .................................................................................... 23
- Microsoft Excel Code ................................................................................................ 24
- Microsoft Excel Output .............................................................................................. 25
- Microsoft Visual C++ Example .................................................................................. 26
- Microsoft Visual C++ Configuration ......................................................................... 26
- Microsoft Visual C++ Code ....................................................................................... 26
- Microsoft Visual C++ Output ..................................................................................... 28
- Agilent VEE Example ................................................................................................ 29
- Agilent VEE Configuration ......................................................................................... 29
- Agilent VEE Code ....................................................................................................... 30
- Agilent VEE Output ................................................................................................... 31
- National Instruments LabVIEW™ Example .............................................................. 32
- LabVIEW Configuration ............................................................................................ 32
- LabVIEW Code ........................................................................................................... 32
- LabVIEW Output ........................................................................................................ 32

## Appendix A: Quick Reference Guide

- Register a User on the PNA ....................................................................................... 33
- Share Drives ............................................................................................................... 33
- Configure COM/DCOM ............................................................................................. 34
- Grant User Access (Windows XP) ............................................................................. 34
- Grant User Access (Windows 2000) ......................................................................... 34
- Configure the PC for DCOM Access ....................................................................... 34

## Appendix B: PNA and PNA-L Models

 ................................................................................................................................. 35
This application note provides a step-by-step guide to system administration, software installation, and COM/DCOM\(^1\) setup for the PNA Series\(^2\) of microwave network analyzers. After reading this application note, you should be able to:

- Add user profiles to your analyzer
- Share drives between your analyzer and a PC running Windows
- Load software on your analyzer over the LAN or from an external CD drive
- Configure your analyzer and PC for COM/DCOM communications

Additionally, this application note provides a simple programming example in six common languages or formats\(^3\) (Microsoft Visual Basic, Visual Basic Script, Word, Excel, Agilent VEE, Visual C++, and National Instruments LabVIEW) that demonstrates the differences between development platforms.

The procedures listed in this application note are valid for a PC with Windows 98 or newer operating systems. This application note was developed on a PC with Windows 2000 Professional version 5.00.2195 with service pack 4. The PNA's operating system was Windows 2000 Professional, however, the steps should be similar for other versions of Windows operating systems.

**How to Use this Document**

Depending upon what you are trying to accomplish, you may not need to perform all of the steps and procedures set forth in this document. Use the following as guideline.

If you want to:

- **Add a user so that they can log into the PNA or use the PNA via DCOM**, perform “Registering as a User on the PNA” on page 4.
- **Transfer files between the PNA and a PC**, perform “Sharing Drives Between the PNA and a PC” on page 6. You may also want to add other users. If so, see “Registering as a User on the PNA” on page 4.
- **Installing software on the PNA**, see “Error! Reference source not found.” on page 8 "Error! Bookmark not defined."
- **Run a program on the PC that accesses the PNA via DCOM**, perform “Registering as a User on the PNA” on page 4, and “Configuring COM/DCOM” on page 10. “Installing Software” on page 8 may also be of interest.

---

1. COM = component object model
2. DCOM = distributed component object model
3. “PNA” or just “analyzer” will be used throughout this document to refer to both PNA and PNA-L network analyzers.
4. Microsoft Word and Excel use Visual Basic for Applications
Basic Administration

Note
This is the same procedure a system administrator must use to grant multiple users permission to log on to the analyzer and maintain their user profile.

Note
When the analyzer is shipped from the factory, the default administrator name is PNA-Admin, and the default password is agilent. This is true of all PNAs shipped after April, 2004. Earlier units had the administrator name of administrator and either a blank password, or the password tsunami.

This section describes how to add a user on the PNA and how to share drives between the analyzer and a PC.

To obtain access to the PNA for COM/DCOM, a user must be registered on the analyzer.

Any drive can be shared between the analyzer and PC, including a CD drive for software installation over the LAN (described in further detail in “Installing Software Over the LAN” on page 8). To configure COM/DCOM communications to and from the PC and analyzer, share the analyzer’s (C:) drive with your PC.

Registering as a User on the PNA

When accessing the PNA from a PC using DCOM, the user must be registered on the PNA using the same name and password as that used on the PC, or the user must follow a special procedure to allow access. That special procedure is not documented here, but can be found at http://na.tm.agilent.com/pna/DCOMSecurity.html.

To register with the user’s PC login and password, refer to the following procedure. The following tasks must be performed by an administrator of the PNA.

On the PNA:
1. Log on to the PNA using the administrator user name and password.
2. Right-click on the My Computer icon, and then click on Manage to launch the Computer Management utility.
3. In the Computer Management window, expand Local Users and Groups and then click on Users to view the current list of users in the right side of the window.
4. Launch the New User window by right-clicking on the Users folder and then clicking on New User. See screenshot, below.
5. Enter the user’s PC login into the **User name** field. Enter the user’s PC password into the **Password** and **Confirm password** fields. Click **Create** when done entering information.

![New User Window](image)

**Note**

The **Full name** and **Description** fields are optional. The **User must change password at next logon** box is the default. In most cases it is recommended that you select **Password never expires**.

6. The **New User** window will not close, but the input boxes are cleared and the check boxes returned to their default settings. Click the **Close** button to close the **New User** window. Notice that the new user has been added to the list in the **Computer Management** window. Close the **Computer Management** window. The user now has access to the PNA.
Sharing Drives Between the PNA and a PC

Any drive can be shared between the analyzer and a PC, including a CD drive for software installation over the LAN. This section contains the steps necessary to share drives between your computer and the analyzer, and specifically shows how to share the (C:) hard drives. These steps may be useful for configuring COM/DCOM access (see page 10).

Both the PC and the PNA must be connected to the same LAN before continuing.

Determine the Full Computer Names of Both Devices

Perform the following steps on both the PC and the PNA:

1. Right-click the My Computer icon, and then click Properties.
2. Click the Network Identification or Computer Name tab to view the Full computer name for the device.

3. Record the computer names here:

   PC name: ___________________________
   PNA name: ___________________________

Note
The following sections describe how to access the PNA's (C:) drive from your PC. You can access your PC's (C:) drive from the analyzer by simply performing the PNA steps on the PC, and vice versa.
Share the PNA’s (C:) Drive

On the PNA:
1. Double-click *My Computer*, right-click on *Local Disk (C:)*, and then select *Sharing*.
2. Ensure that *Share this folder* is selected. If you choose to use a different *Share name* than the default of *C*$, enter it in the *Share name* field and make note of it for future reference.
3. Click *OK* when done.

Map a New Drive on the PC

On the PC:
1. Right-click on *My Computer* and select *Map Network Drive*.
2. The Map Network Drive wizard will select an available drive letter for you. You may also use any other available drive letter. Record the drive letter here: _____.
3. Enter the path to the PNA in the Folder field. The syntax is "\\computername\share name". See the example below.

4. If you want your PC to automatically map this drive every time you log on to your PC, select *Reconnect at logon*.
5. Click *Finish*. (If the user name/password is not identical on both the PC and the PNA, Windows will first ask for a valid name and password.) Verify that the drive is visible in the *My Computer* folder on your PC.

---

**Note**
In some cases, sharing the entire (C:) drive may be a security risk. It may be better to create a separate folder called shared, and only share this folder.
Installing Software

This section assumes that you will be installing software from a CD-ROM. You can either use your PC’s CD-ROM drive, or a USB external CD-ROM drive connected to the PNA.

If you will be using the CD-ROM drive on your PC to install the software on the analyzer, go to “Installing Software Over the LAN” below. Otherwise, if you will be using an external USB CD-ROM drive connected to the PNA, go to “Installing Software from External USB CD-ROM Drive” on page 9.

Installing Software Over the LAN

If you do not have access to a USB external CD-ROM drive for your PNA, it is possible to map your PC’s CD-ROM drive to the PNA. Both your PC and the analyzer must be connected to the LAN. The software can then be installed from your PC’s CD drive.

Map the PC’s CD-ROM Drive to the PNA

On the PC:
1. Double-click My Computer. Right-click on the icon that represents the CD-ROM drive, and select Properties.
2. Select the Sharing tab and record the Share name of the CD-ROM drive here: ______.
3. Obtain your PC’s full computer name. See “Determine the Full Computer Names of Both Devices” on page 6.

On the PNA:
4. Map a drive from the PNA to the PC’s CD-ROM drive. See steps 1 through 5 on page 7 for general instructions. Be sure to perform these steps on the PNA and to use the computer name of the PC along with the share name obtained in step 2, above.

Install the Software
5. Insert the software CD into your PC’s CD-ROM drive.
6. On the PNA, double-click My Computer and then double-click the icon representing the new drive that was mapped in step 4.
7. Refer to your software’s documentation to determine which file to run for setup and installation. Be sure to choose the PNA’s (C:) drive as the destination for file installation.

Note

NOTE: If your user settings (see step 5 on page 5) were set to something other than your PC login and password, you will need to “Connect using different user name.”
Installing Software from External USB CD-ROM Drive

This procedure was verified for an Iomega Predator CD-RW drive. Perform all steps in this procedure on the PNA. If your PNA already has an external USB CD drive connected, skip to step 5.

Connect the External CD Drive to the PNA
1. Exit all applications, including the network analyzer application.
2. Connect the external CD drive to an available USB port on the analyzer or to a USB hub that is connected to the analyzer.
3. If applicable, connect the power cord for the CD drive to an available outlet. If the drive has an on/off switch, switch the CD drive to On.
4. The Windows system in the PNA should automatically recognize and install the new CD drive. Follow any instructions for installing drivers and/or rebooting the system. (If you are using the CD drive for reading files only (no writing), then drivers should not be necessary.)

Install the Software
5. Insert the software CD into the external CD drive.
6. Most software CDs are designed to start automatically. If the setup application for your software does not start, refer to the software documentation to determine which file to run for setup and installation.
This section briefly describes the concepts of workgroups and domains. It then explains the steps necessary to grant DCOM access to a specific user, and finally describes how to configure the user’s PC for DCOM access.

**Workgroups versus Domains**

Before continuing you may need to consider the differences between setting up the PNA as a member of a workgroup or a domain.

- A **workgroup** is established and maintained by the PNA administrator. The PNA is shipped from the factory configured as a member of a workgroup named WORKGROUP. Also by default from the factory, **Everyone** (all members of WORKGROUP) has permission to launch and access the PNA application via COM/DCOM.

- A **domain** is typically a large organizational group of computers. A network administrator must establish and maintain the domain and control which devices have membership in the domain.

This document assumes that the analyzer will remain a member of a workgroup. It also assumes that the PNA administrator will want to give specific users (not **Everyone**) COM/DCOM permissions.
Granting Access to a Specific User

You may not need to perform this procedure. Read the following note to determine whether or not you want to do this.

Select the appropriate procedure below depending on your operating system.

Windows XP Procedure for Granting Access

Minimize the PNA application before beginning. All steps in this procedure are performed on the PNA.

1. Click the Windows Start button, then select Run. Enter “dcomcnfg” into the text box and click OK.
2. Open the following folder sequence:
   - Component Services Window
   - Component Services
   - Computers
   - My Computer
   - DCOM Config
3. Right-click on Agilent PNA Series, then click Properties.
4. Select the Security tab and click Customize under Access Permissions, and then click the Edit... button.
5. Select Everyone, then click Remove.
6. Click Add and type a group name or user account name to add. Click OK.
7. Under Launch Permissions, click Customize, then click Edit.
8. Select Everyone, then click Remove.
9. Click Add and type a group name or user account name to add. Click OK.

Windows 2000 Procedure for Granting Access

Minimize the PNA application before beginning. All steps in this procedure are performed on the PNA.

1. Click the Windows Start button, then select Run. Enter “dcomcnfg” into the text box and click OK. The Distributed COM Configuration Properties window should appear.
2. Make sure the Applications tab is on top, select Agilent PNA Series, and then click the Properties... button.
3. Select the Security tab, click Use custom access permissions, and then click the Edit... button.
4. In Registry Value Permission, select Everyone, then click Remove.
5. Click Add and then select one or more groups, or specific users. To give specific users access, click Show Users or Members, then select the name from the list.
6. Click Add, then click OK.
7. Click Use custom launch permissions, then click Edit.
8. In Registry Value Permissions, select Everyone, then click Remove.
9. Click Add, and then select one or more groups, or specific users. To give specific users launch permission, click Show Users or Members, then select the name from the list.
10. Click Add, then click OK.

---

Note
The analyzer is shipped from the factory granting access to “Everyone.” Everyone is defined as only those users who have been given logon accounts on the PNA. Use the following procedure only if you want to prevent Everyone from having DCOM access to the PNA, and to allow DCOM access only to those individuals that you specify.
Configuring the PC for DCOM Access

On your PC, there is a registry file that keeps track of where object models are located. Therefore, you must register the type library on the PC that will be used to develop code and run the program. A program called `pnaproxy.exe` will perform all the necessary tasks. This program is located on the PNA's hard drive in the following location:

C:\Program Files\Agilent\Network Analyzer\Automation

Copy the `pnaproxy.exe` program (approximately 5 MB) to any convenient location on your PC. You can use a USB pen drive, or you can map a drive to the PNA from your PC and copy it over the LAN. See “Map a New Drive on the PC” on page 7.

The procedure below will accomplish the following:

- Register the network analyzer application on your PC
- Copy and register the proxystub (835xps.dll) onto your PC
- Copy and register the PNA type library (835x.tlb) onto your PC
- Copy and register the FCA\(^1\) type library (fca.tlb) onto your PC

1. Close any applications that are currently running on your PC.
2. Navigate to, and double-click the `pnaproxy.exe` file that you copied to your PC.
3. Follow the instructions to install PNA proxy. (If the installation offers a choice, of Modify, Repair, or Remove, select Remove. Then double-click on `pnaproxy.exe` again when it has finished.)
4. When prompted, type the computer name of the PNA that you want to use as the default target. See “Determine the Full Computer Names of Both Devices” on page 6 for information on determining the name of the PNA. Alternately, you can provide a fixed IP address instead of a name.
5. When the installation is complete, the PNA and FCA type libraries should be registered on your PC.
6. Your programming environment may require you to set a reference to the PNA type library that is now located on your PC. For example, in Visual Basic, click Project > References. Then browse to `C:\Program Files\Common Files\Agilent\PNA` and select `835x.tlb`.

If You Encounter Problems

- Be sure that you do not have any applications running on the PC.
- Check that both the account name and password used on both the PNA and PC match exactly.
- Repeat the procedure outlined in “Configuring the PC for DCOM Access” above.

\(^1\) FCA = frequency converter application

---

**Note**

To register the type library on your PC, you must be logged on as an administrator of your PC.
The analyzer’s support for DCOM over the LAN provides control of the PNA using a variety of platforms. DCOM acts as an interface to the analyzer for external applications. With DCOM, the programmer can develop an application on an external computer. During development, the application will interface to the analyzer over the LAN through the DCOM interface. Once the developer has finished the application, it can be distributed to the analyzer. After it has been distributed to the analyzer, the application will interface with the PNA using COM.

The example applications in this application note were developed in a number of different programming languages to show the differences between development platforms. The application was first developed on a PC and then transferred to the analyzer once development was complete. The table below outlines the setup parameters that the applications will use to configure the PNA analyzer for a measurement:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start frequency</td>
<td>1 GHz</td>
</tr>
<tr>
<td>Stop frequency</td>
<td>2 GHz</td>
</tr>
<tr>
<td>Number of points</td>
<td>11</td>
</tr>
<tr>
<td>Measurement</td>
<td>$S_{11}$</td>
</tr>
<tr>
<td>Data storage area</td>
<td>Uncorrected (Raw Data)</td>
</tr>
<tr>
<td>Data format</td>
<td>Log Magnitude</td>
</tr>
<tr>
<td>Trigger mode</td>
<td>Single</td>
</tr>
</tbody>
</table>

The device tested was a 50 ohm standard load on port 1 of the PNA.

You can download the example programs and obtain more detailed information for each development environment from [http://na.tm.agilent.com/pna](http://na.tm.agilent.com/pna)

The development environment should reference the type library associated with the PNA. For example, in Visual Basic, add the “Agilent PNA Series 1.9 Type library” as a reference. This will allow the program to “see” the various classes and methods available for use with the analyzer during development. (See the individual programming examples that follow for more information.)
Microsoft Visual Basic Example

Visual Basic Configuration

The type library for the PNA should be referenced in the Visual Basic development environment. The following figure has the type library for the PNA highlighted.

Using the Visual Basic Object Browser the developer can see what classes and methods are available for development of applications for the analyzer (see figure below).
Visual Basic Code

The application code is contained below. To run the application, first generate the executable file. Once this is complete, it can be copied and executed on the analyzer or run on the PC. The application can also be run from the development environment.

Option Explicit

Dim app As AgilentPNA835x.Application
Dim chan As AgilentPNA835x.Channel
Dim meas As AgilentPNA835x.Measurement
Dim result As Variant
Dim i As Integer
Dim num_points As Integer
Dim message As String

Private Sub Main()
    'Connect to the PNA application on machine SLTSU044
    Set app = CreateObject("AgilentPNA835x.Application","SLTSU044")

    'Reset the analyzer to instrument preset
    app.Reset

    'Create S11 measurement
    app.CreateMeasurement 1, "S11", 1

    'Set chan variable to point to the active channel
    Set chan = app.ActiveChannel

    'Set meas variable to point to the active measurement
    Set meas = app.ActiveMeasurement

    'Setup the channel for a single trigger
    chan.Hold True
    app.TriggerSignal = naTriggerManual
    chan.TriggerMode = naTriggerModeMeasurement

    'Make the PNA application visible
    app.Visible = True

    'Set channel parameters
    chan.NumberOfPoints = 11
    chan.StartFrequency = (1000000000#)
    chan.StopFrequency = (2000000000#)

    'Send a manual trigger to initiate a single sweep
    chan.Single True

    'Store the data in the "result" variable
    result = meas.GetData(naRawData, naDataFormat_LogMag)

    'Display the result
    num_points = chan.NumberOfPoints
    For i = 0 To num_points - 1
        message = message & result(i) & vbCrLf
    Next

    If MsgBox(message, vbOKOnly, "S11(dB) - VBS COM Example for PNA") Then
        Set chan = Nothing
        Set app = Nothing
    End If
End Sub

Note
Be sure to edit the first line of code in Sub Main to include the name of your analyzer.
Visual Basic Output
The figure below shows the displayed results when the application is executed.

![Visual Basic Output](image)

-30.28902
-30.34884
-30.55416
-30.93093
-31.45908
-32.13876
-33.14954
-34.29582
-35.5127
-36.48022
-37.01794
Microsoft Visual Basic Script (VBScript) Example

VBScript Configuration
Some operating systems may require that the Visual Basic Scripting engine be installed before running the application on a PC. To download a free copy of a Visual Basic Scripting engine, visit the following web site: http://msdn.microsoft.com/scripting/

VBScript Code
The application code is contained below. The developer must save the file in a text file (i.e. using notepad) and save it with the "vbs" extension. The "vbs" extension will tell the operating system to execute the code using the Visual Basic Scripting engine. In order to run the application, double-click on the saved .vbs file. The application can be run on a PC or copied and run on the PNA.

```vbscript
Option Explicit

' Shell objects
Dim app
Dim chan
Dim meas
Dim result
Dim message
Dim num_points
Dim I

' Connect to the PNA application on machine SLTSU044
Set app = CreateObject("AgilentPNA835x.Application","SLTSU044")

' Reset the analyzer to instrument preset
app.Reset

' Create S11 measurement
app.CreateMeasurement 1, "S11", 1

' Set chan variable to point to the active channel
Set chan = app.ActiveChannel

' Set meas variable to point to the active measurement
Set meas = app.ActiveMeasurement

' Setup the channel for a single trigger
chan.Hold True
app.TriggerSignal = 3
chan.TriggerMode = 1

' Make the PNA application visible
app.Visible = True

' Set channel parameters
chan.NumberOfPoints = 11
chan.StartFrequency = (1000000000)
chan.StopFrequency = (2000000000)

' Send a manual trigger to initiate a single sweep
chan.Single True

' Store the data in the "result" variable
result = meas.GetData(0, 1)

' Display the result
num_points = chan.NumberOfPoints
For i = 0 To num_points - 1
    message = message & result(i) & vbCRLF
Next

if MsgBox(message, vbOKOnly, "S11(dB) - VBS COM Example for PNA") then
    Set chan = Nothing
    Set app = Nothing
end if
```

Note
Be sure to edit the "Set app = CreateObject..." code to include the name of your analyzer.
VB Script Output
The figure below shows the displayed results when the application is executed.

-30.20962
-30.34884
-30.55416
-30.93093
-31.45908
-32.13876
-33.14954
-34.29582
-35.5127
-36.48022
-37.01794
Microsoft Word Example

Microsoft Word Configuration
Microsoft® Office 2000 was used for this example. This version of Office contains Visual Basic for Applications (VBA) which allows developers to attach Visual Basic Macros to Word documents. To run this example:

1. Create a new Word document with a table that has 2 columns and 12 rows as shown below. Enter the headings into the first row, and the frequency values in the first column.

<table>
<thead>
<tr>
<th>Frequency in MHz</th>
<th>$S_H$ in dB</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.0</td>
<td></td>
</tr>
<tr>
<td>1.1</td>
<td></td>
</tr>
<tr>
<td>1.2</td>
<td></td>
</tr>
<tr>
<td>1.3</td>
<td></td>
</tr>
<tr>
<td>1.4</td>
<td></td>
</tr>
<tr>
<td>1.5</td>
<td></td>
</tr>
<tr>
<td>1.6</td>
<td></td>
</tr>
<tr>
<td>1.7</td>
<td></td>
</tr>
<tr>
<td>1.8</td>
<td></td>
</tr>
<tr>
<td>1.9</td>
<td></td>
</tr>
<tr>
<td>2.0</td>
<td></td>
</tr>
</tbody>
</table>

2. In the Word application, select Tools > Macro > Visual Basic Editor.
3. Double-click ThisDocument in the Visual Basic Editor Project window.
4. Copy the code from Microsoft Word Code on page 21 into the Visual Basic Editor window.

5. The type library for the PNA should be referenced in the Visual Basic development environment. (Select Tools > References in the Visual Basic Editor, and be sure to select the Agilent PNA Series Type Library.) See the screenshot on page 14 for an example of the References window.

6. Save and close the file.

**Note**
In this example the “CreateObject” method will look at the configuration of DCOM to see what machine to connect to.
Microsoft Word Code

The application code is contained below. The program inserts the data retrieved from the analyzer into an existing table in a Word document. To run the application, open the document using Microsoft Word. Enable the macros when prompted. Once this is complete, the application will execute and update the document. The application can be run on a PC or the analyzer.

Option Explicit
Dim app
Dim chan
Dim meas
Dim result As Variant
Dim i As Integer
Dim num_points As Integer
Private Sub Document_Open()
    'Connect to the PNA application on machine SLTSU044
    Set app = CreateObject("AgilentPNA835x.Application","SLTSU044")
    'Reset the analyzer to instrument preset
    app.Reset
    'Create S11 measurement
    app.CreateMeasurement 1, "S11", 1
    'Set chan variable to point to the active channel
    Set chan = app.ActiveChannel
    'Set meas variable to point to the active measurement
    Set meas = app.ActiveMeasurement
    'Setup the channel for a single trigger
    chan.Hold True
    app.TriggerSignal = naTriggerManual
    chan.TriggerMode = naTriggerModeMeasurement
    'Make the PNA application visible
    app.Visible = True
    'Set channel parameters
    chan.NumberOfPoints = 11
    chan.StartFrequency = (1000000000#)
    chan.StopFrequency = (2000000000#)
    'Send a manual trigger to initiate a single sweep
    chan.Single True
    'Store the data in the "result" variable
    result = meas.GetData(naRawData,naDataFormat_LogMag)
    'Display the result
    num_points = chan.NumberOfPoints
    For i = 0 To num_points - 1
        ThisDocument.Tables(1).Cell(i + 2, 2).Range = result(i)
    Next
    Set chan = Nothing
    Set app = Nothing
End Sub

Note
Be sure to edit the first line of code in Sub Document_Open to include the name of your analyzer.
Microsoft Word Output
The figure below shows the displayed results when the application is executed.

<table>
<thead>
<tr>
<th>Frequency in MHz</th>
<th>$S_{11}$ in dB</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.0</td>
<td>-30.666699</td>
</tr>
<tr>
<td>1.1</td>
<td>-30.66298</td>
</tr>
<tr>
<td>1.2</td>
<td>-30.8582</td>
</tr>
<tr>
<td>1.3</td>
<td>-31.1689</td>
</tr>
<tr>
<td>1.4</td>
<td>-31.84268</td>
</tr>
<tr>
<td>1.5</td>
<td>-32.23172</td>
</tr>
<tr>
<td>1.6</td>
<td>-33.18055</td>
</tr>
<tr>
<td>1.7</td>
<td>-34.23394</td>
</tr>
<tr>
<td>1.8</td>
<td>-35.35485</td>
</tr>
<tr>
<td>1.9</td>
<td>-36.36187</td>
</tr>
<tr>
<td>2.0</td>
<td>-37.03015</td>
</tr>
</tbody>
</table>
Microsoft Excel Example

Microsoft Excel Configuration
Microsoft® Office 2000 was used for this example. This version of Office contains Visual Basic for Applications (VBA) which allows developers to attach Visual Basic Macros to Excel documents. To run this example:

1. Create and format a new Excel document with appropriate text headings and graphs if desired. The program will insert $S_{11}$ values in column A, cells 3 through 13.
2. In the Excel application, select Tools > Macro > Visual Basic Editor.
3. Double-click ThisWorkbook in the Visual Basic Editor Project window. Copy the code from Microsoft Excel Code on page 30 into the Visual Basic Editor window.
4. The type library for the PNA should be referenced in the Visual Basic development environment. (Select Tools > References in the Visual Basic Editor, and be sure to select the Agilent PNA Series Type Library.) See the screenshot on page 14 for an example of the References window.
5. Save and close the Excel file.
Microsoft Excel Code

The application code is contained below. The program inserts the data retrieved from the analyzer into cells A3 through A13 in the Excel document. To run the application, open the document using Microsoft Excel. Enable the macros when prompted. Once this is complete, the application will execute and update the document. You can then create a graph (as shown in the example on page 32). The data and graph will then update with each subsequent run of the application. The application can be run on a PC or the analyzer.

Option Explicit
Dim app
Dim chan
Dim meas
Dim result As Variant
Dim i As Integer
Dim num_points As Integer

Private Sub Workbook_Open()
    'Connect to the PNA application on machine SLTSU044
    Set app = CreateObject("AgilentPNA835x.Application","SLTSU044")
    'Reset the analyzer to instrument preset
    app.Reset
    'Create S11 measurement
    app.CreateMeasurement 1, "S11", 1
    'Set chan variable to point to the active channel
    Set chan = app.ActiveChannel
    'Set meas variable to point to the active measurement
    Set meas = app.ActiveMeasurement
    'Setup the channel for a single trigger
    chan.Hold True
    app.TriggerSignal = naTriggerManual
    chan.TriggerMode = naTriggerModeMeasurement
    'Make the PNA application visible
    app.Visible = True
    'Set channel parameters
    chan.NumberOfPoints = 11
    chan.StartFrequency = (1000000000#)
    chan.StopFrequency = (2000000000#)
    'Send a manual trigger to initiate a single sweep
    chan.Single True
    'Store the data in the "result" variable
    result = meas.GetData(naRawData, naDataFormat_LogMag)
    'Display the result
    num_points = chan.NumberOfPoints
    For i = 0 To num_points - 1
        Sheet1.Cells(3 + i, 1) = result(i)
    Next
    Set chan = Nothing
    Set app = Nothing
End Sub
Microsoft Excel Output
The figure below shows the displayed results when the application is executed.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
<th>I</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Return Loss Data in dB</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td>-30.72144659</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td>-30.6219861</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td>-30.6219861</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td></td>
<td>-31.6219861</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td></td>
<td>-31.6219861</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td></td>
<td>-31.6219861</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td></td>
<td>-31.6219861</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>9</td>
<td></td>
<td>-31.6219861</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>10</td>
<td></td>
<td>-31.6219861</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td></td>
<td>-31.6219861</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td></td>
<td>-31.6219861</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>13</td>
<td></td>
<td>-31.6219861</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>14</td>
<td></td>
<td>-31.6219861</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>15</td>
<td></td>
<td>-31.6219861</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>16</td>
<td></td>
<td>-31.6219861</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>17</td>
<td></td>
<td>-31.6219861</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

![Graph showing Return Loss Data in dB](image_url)
Microsoft Visual C++ Example

Microsoft Visual C++ Configuration
Microsoft Visual C++ version 6 was used for this example. In order to perform this example, create a new project in Microsoft Visual C++. Add a C++ file to the project and paste the following code into the file. The path for the type library in the code below should be changed to reference its location on the development PC.

Microsoft Visual C++ Code
The application can be run on a PC or on the PNA.

```c
#include <stdio.h>
#include "atlbase.h"
#include "objbase.h"

// import the PNA type library
//----------------------------------------------------------------
#import "C:\Program Files\Common Files\Agilent\PNA\835x.tlb"
no_namespace, named_guids
int main(int argc, char* argv[])
{
    // interface pointers to retrieve COM interfaces
    IUnknown* pUnk = 0;
    IApplication* pNA = 0;
    IChannel* pChan = 0;
    IMeasurement* pMeas = 0;
    IArrayTransfer* pTrans = 0;
    int i, num_points = 0;
    float* pScalarData;

    HRESULT hr;
    // Initialize the COM subsystem
    CoInitialize(NULL);
    CoInitializeSecurity( NULL, //security descriptor
        0, // authn svc entries
        NULL, // authn svcs
        NULL, // reserved
        RPC_C_AUTHN_LEVEL_NONE,
        RPC_C_IMP_LEVEL_ANONYMOUS,
        0, // authn info
        0, // capabilities
        0); // reserved

    // Create an instance of the network analyzer
    // Request the NA’s IUnknown interface
    hr = CoCreateInstance(CLSID_Application,0,CLSCTX_ALL,
        IID_IUnknown, (void**) &pUnk);
    if (!FAILED(hr))
    {
        // QueryInterface for the INetworkAnalyzer interface of the
        // NetworkAnalyzer object
        hr = pUnk->QueryInterface(IID_IApplication,(void**) &pNA);
        if (!FAILED(hr))
        {
            // Reset the analyzer to instrument preset
            pNA->Reset();
            // Create S11 measurement
            pNA->CreateSParameter(1,1,1,1);
            // Set pChan variable to point to the active channel
            pNA->get_ActiveChannel(&pChan);
            if (pChan)
            {
                // Set pMeas variable to point to the active measurement
                pNA->get_ActiveMeasurement(&pMeas);
            }
        }
    }
```


if(pMeas)
{
    // Setup the channel for a single trigger
    pChan->Hold(true);
    pNA->TriggerSignal = naTriggerManual;
    pChan->TriggerMode = naTriggerModeMeasurement;

    // Make the PNA application visible
    pNA->put_Visible(true);

    // Set channel parameters
    pChan->NumberOfPoints = 11;
    pChan->StartFrequency = 1e9;
    pChan->StopFrequency = 2e9;

    // Send a manual trigger to initiate a single sweep
    pChan->Single(true);

    // QueryInterface for the IArrayTransfer interface of the
    // NetworkAnalyzer object
    hr = pMeas >QueryInterface(IID_IArrayTransfer,
                              (void**)&pTrans);
    if (!FAILED(hr))
    {
        // Store the data in the "result" variable
        num_points = pChan->NumberOfPoints;
        pScalarData = new float[num_points];
        pTrans->getScalar(naRawData, naDataFormat_LogMag,
                          (long *)&num_points, pScalarData);

        // Display the result
        printf("S11(dB) - Visual C++ COM Example for PNA\n\n");
        for (i = 0; i < num_points; i++)
            printf("%f
", pScalarData[i]);
    }
}
}
pUnk->Release();
pMeas->Release();
pChan->Release();
pTrans->Release();
pNA->Release();

else
{
    printf("Programmed failed to connect to the PNA.");
}

CoUninitialize();
return 0;
}
Microsoft Visual C++ Output

The figure below shows the displayed results when the application is executed.
Agilent VEE Example

Agilent VEE Configuration
For this example use Agilent VEE version 6.0 or above which contains the Variant data type used to transfer data from the PNA. The type library for the PNA should be referenced in the Agilent VEE development environment (select **Device > ActiveX Automation References...** in the Vee IDE). The following figure illustrates the reference.

![ActiveX Automation References](image)

Using the Agilent VEE Object Browser (select **Device > Function & Object Browser**) the developer can see what classes and methods are available for development of applications for the PNA Series analyzer (see figure below).

![Function & Object Browser](image)
Agilent Vee Code
Agilent VEE version 6.0 or higher must be installed to run the application in this example. There is a runtime version of Agilent VEE that may be used if the application has been saved as “runtime.” A free trial version of Agilent VEE can be found on the following website: [http://www.agilent.com/find/vee/](http://www.agilent.com/find/vee/)

The application may be run on a PC or on the PNA Series analyzer. The following screenshot shows the example program.
Agilent Vee Output
The figure below shows the displayed results when the application is executed.

S11(dB) - Agilent VEE COM Example for PNA

-30.78414154052734
-30.76251792907715
-30.92657661437988
-31.21685028076172
-31.66900444030762
-32.25442123413086
-33.14598083496094
-34.18373870849609
-35.29323577880860
-36.29581832885742
-36.91405868530273
National Instruments LabVIEW™ Example

LabVIEW Configuration
Use National Instruments LabVIEW version 5.0 or above for this example. See the National Instruments LabVIEW documentation or online help for information on using ActiveX objects in the LabVIEW development environment.

LabVIEW Code
National Instruments LabVIEW 5.0 or higher must be installed to run the application. The application can be run on a PC or on the PNA Series analyzer. The screenshot below was taken from LabVIEW 7.0.

LabVIEW Output
The figure below shows the displayed results when the application is executed. Again, this screenshot was taken from LabVIEW 7.0.
This section is intended to be used as a quick reference for the steps necessary to register a user on the PNA, share drives between a PC and the PNA, and to configure COM/DCOM. This is just a repeat—in abbreviated form—of information that is contained in more detail in Basic Administration beginning on page 4, and in “Configuring COM/DCOM” beginning on page 10. Please refer back to these sections if you need more detailed information.

Register a User on the PNA

1. Log on to the PNA as administrator.
2. Right-click My Computer > Manage.
3. Local Users and Groups > right-click Users > New User
4. Enter User name and Password/Confirm Password (use PC login and password).
5. Create > Close

Share Drives

On the PNA:
1. My Computer > right-click Local Disk(C:) > Sharing > Share this folder
2. Optional: Change Share name if desired.

On the PC:
1. Right-click My Computer > Map Network Drive
2. Select Drive, enter path (syntax:\\computername\sharename, i.e. \\agilent-kppfmj5\c$) in Folder > Finish.
Configure COM/DCOM

Grant User Access (Windows XP)
Please read the note on page 11 to determine whether or not you want to perform this procedure.

On the PNA:
1. Minimize the PNA application, and click Start > Run > dcomcnfg > OK
2. Open the following folder sequence:
   Component Services Window
   Component Services
   Computers
   My Computer
   DCOM Config
3. Right-click Agilent PNA Series > Properties
4. Select Security tab > Customize (under Access Permissions) > Edit...
5. Select Everyone > Remove, then click Add and type a group name or user account name
6. Click Customize (under Launch Permissions) > Edit...
7. Select Everyone > Remove, then click Add and type a group name or user account name

Grant User Access (Windows 2000)
Please read the note on page 11 to determine whether or not you want to perform this procedure.

On the PNA:
1. Minimize the PNA application, and click Start > Run > dcomcnfg > OK
2. On Applications tab, select Agilent PNA Series > Properties...
3. Select Security tab > Use custom access permissions > Edit...
4. In Registry Value Permission, select Everyone > Remove, then click Add and select one or more groups or users.
5. Click Add > OK

Configure the PC for DCOM Access

On the PC:
1. Close any applications that are running.
2. Copy Program Files\Agilent\Network Analyzer\Automation\pnaproxy.exe from the PNA to a convenient place on your PC.
3. Run pnaproxy.exe
Appendix B: PNA and PNA-L Models

The procedures in this document apply to the following list of Agilent analyzers. Note that the procedures herein may apply to newer analyzers that had not yet been introduced at the time this document was created.

E8356A
E8357A
E8358A
N3381A
N3382A
N3383A
E8801A
E8802A
E8803A
E8362A/B
E8363A/B
E8364A/B
N5230A
N5250A
Web Resources

Visit our web sites for additional product information and literature.

PNA microwave network analyzers:
www.agilent.com/find/pna

Electronic calibration (ECal):
www.agilent.com/find/ecal

Test and measurement accessories:
www.agilent.com/find/accessories

Agilent Technologies’ Test and Measurement Support, Services, and Assistance
Agilent Technologies aims to maximize the value you receive, while minimizing your risk and problems. We strive to ensure that you get the test and measurement capabilities you paid for and obtain the support you need. Our extensive support resources and services can help you choose the right Agilent products for your applications and apply them successfully. Every instrument and system we sell has a global warranty. Support is available for at least five years beyond the production life of the product. Two concepts underlie Agilent’s overall support policy: “Our Promise” and “Your Advantage.”

Our Promise
Our Promise means your Agilent test and measurement equipment will meet its advertised performance and functionality. When you are choosing new equipment, we will help you with product information, including realistic performance specifications and practical recommendations from experienced test engineers. When you receive your new Agilent equipment, we can help verify that it works properly and help with initial product operation.

Your Advantage
Your Advantage means that Agilent offers a wide range of additional expert test and measurement services, which you can purchase according to your unique technical and business needs. Solve problems efficiently and gain a competitive edge by contracting with us for calibration, extra-cost upgrades, out-of-warranty repairs, and onsite education and training, as well as design, system integration, project management, and other professional engineering services. Experienced Agilent engineers and technicians worldwide can help you maximize your productivity, optimize the return on investment of your Agilent instruments and systems, and obtain dependable measurement accuracy for the life of those products.

Agilent T&M Software and Connectivity
Agilent’s Test and Measurement software and connectivity products, solutions and developer network allows you to take time out of connecting your instruments to your computer with tools based on PC standards, so you can focus on your tasks, not on your connections. Visit www.agilent.com/find/connectivity for more information.

For more information on Agilent Technologies’ products, applications or services, please contact your local Agilent office. The complete list is available at:
www.agilent.com/find/contactus

Product specifications and descriptions in this document subject to change without notice.

Phone or Fax

United States:
(tel) 800 829 4444
(fax) 800 829 4433
Canada:
(tel) 877 894 4414
(fax) 905 282 6495
China:
(tel) 800 810 0189
(fax) 800 820 2816
Europe:
(tel) 31 20 547 2111
Japan:
(tel) (81) 426 56 7832
(fax) (81) 426 56 7840

Korea:
(tel) (080) 769 0800
(fax) (080) 769 0900
Latin America:
(tel) (800) 269 7600
Taiwan:
(tel) 0800 047 866
(fax) 0800 286 331
Other Asia Pacific Countries:
(tel) (65) 6375 8100
(fax) (65) 6755 0042
Email: tm_ap@agilent.com

© Agilent Technologies, Inc. 2004
Printed in USA, September 1, 2004
5989-2666EN